relay.nix 451 B

1234567891011121314151617181920212223
  1. { lib
  2. , nixosTests
  3. , rustPlatform
  4. }:
  5. rustPlatform.buildRustPackage {
  6. pname = "relay";
  7. version = "0.3.106";
  8. src = ./.;
  9. cargoLock.lockFile = ./Cargo.lock;
  10. RUSTFLAGS = "--cfg tokio_unstable";
  11. nativeBuildInputs = [ ];
  12. passthru.tests = { inherit (nixosTests) relay; };
  13. meta = with lib; {
  14. description = "An ActivityPub relay";
  15. homepage = "https://git.asonix.dog/asonix/relay";
  16. license = with licenses; [ agpl3Plus ];
  17. };
  18. }